I have just completed the SLES10-SP4 update on a couple of OES2-SP3 servers and see some module conflicts.

Code:
server:~ # SPident -vv

Summary               (using 1158 packages)
Product/ServicePack     conflict        match  update      (shipped)
SLE-10-x86_64            0    0%    284 24.5%     155   (2754 10.3%)
SLE-10-x86_64-SP1        0    0%    369 31.9%     167   (2938 12.6%)
SLE-10-x86_64-SP2        0    0%    479 41.4%     167   (3111 15.4%)
SLE-10-x86_64-SP3        1  0.0%    613 52.9%     177   (3275 18.7%)
  - supportutils  1.20-41.1 < 1.01-45.13.12
SLE-10-x86_64-SP4        4  0.2%    706 61.0%     151   (2390 29.5%)
  - fuse  2.7.2-15.4 < 2.7.2-15.8.1
  - libfuse2  2.7.2-15.3 < 2.7.2-15.8.1
  - ruby  1.8.6.p369-0.5 < 1.8.6.p369-0.10.1
  - supportutils  1.20-41.1 < 1.20-0.10.29
Unknown                             390 33.7%

 Legend for Package Details:
  -  conflicting package (found < expected)

CONCLUSION: System is NOT up-to-date!
  found    SLE-10-x86_64-SP2 + "online updates"
  expected SLE-10-x86_64-SP4

server:~ #
  • What is the correct supportutils version? I tried to install 1.20-0.10.1 but encountered several dependency issues.
  • What might be preventing updates to fuse, libfuse2, and ruby?