I have Visio 2003 Std installed locally on Windows XP Sp3. When I run a Virtualized Visio 2010 Std on the same PC, Visio 2003 tries to reconfigure itself.
I have added the NoReReg registry entry for Visio.
I made %USERPROFILE%\Local Settings\Application Data\Microsoft\Visio Fully isolated because running Visio 2010 std creates two files in this directory.(content14.dat and thumbs.dat)
I have the MS Office 2010 Deployment kit for App-V installed with the property VISIOSTD=1.
I run the ospp.vbs from the office14 directory to make sure the inpkey:767HD-QGMWX-8QTDB-9G3R2-KHFGJ gets injected so the KMS server validates it as Visio Standard and not Visio Premium.
I ran setup /admin to make the MSP and put it in the updates directory, took a before snapshot ran setup, launched visio a few times and waited for it to validate.
Then I finished the snapshot.
It works fine on a PC without Visio 2003 installed.
I have made everything in HKCU fully isolated and this broke the app with a memory error. and tried numerous iterations of registry entries without success.
I virtualized MS Project 2010 Std and pro with no problems.
Any help pointing me in the right direction would be greatly appreciated.

Bob O'D