I have a particular model of HP desktop (8000 USDT) that will not find work to do when setting up hardware rules. I have the same rules built for the 8000 SFF, 8200 USDT and 8200 SFF that all work properly. I am looking at the "Product Name" field for containing 8000 and USDT which is what I have for the other models with the correct number and form factor and they work just fine.

I have the box checked to Force Download in the hardware rule and have removed the object from ZCC. I have also ran the zisedit -r and -c commands with no luck.

In the novell-pbserv log I do get the following which may mean something to someone:

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~
(This is from the failed attempt on an 8000 USDT Note the xml lines near the bottom)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~
10/26/11 10:36:20 -- [LicenseCheck] Checking Imaging License
10/26/11 10:36:20 -- [RNT] Server GUID is: 560ccfc3e30e05417c772b0c684de12c
10/26/11 10:36:20 -- [RNT] Imaging License Info: 1
10/26/11 10:36:20 -- [LC] open connection, 10.20.0.187
10/26/11 10:36:20 -- [PCV] received PROXY_CMD_VERSION
10/26/11 10:36:20 -- [HC] versions: 10, 10, 110010
10/26/11 10:36:20 -- [PCV] done PROXY_CMD_VERSION
10/26/11 10:36:20 -- [PCGNT] received PROXY_CMD_GET_NEXT_STEP
10/26/11 10:36:20 -- [RNT] GWIL = 5176
10/26/11 10:36:20 -- [RNT] Received Workstation Information:
Dumping Workstation Information:
WorkstationInformation.signature ............ ZENWSINF
WorkstationInformation.version .............. 6
WorkstationInformation.length ............... 5176
WorkstationInformation.Chipset .............. Intel 3000 Mhz
WorkstationInformation.Video ................ Intel Corporation Unknown device 0x2E13
WorkstationInformation.Network .............. Intel Corporation Unknown device 0x10DE
WorkstationInformation.Soundcard ............ Intel Corporation Unknown device 0x3A6E
WorkstationInformation.Diskcontroller ....... Intel Corporation Unknown device 0x2E16
WorkstationInformation.MACAddress............ 18:a9:05:ef:87:d3
WorkstationInformation.ipAddress ............ 10.20.0.187
WorkstationInformation.BiosAssetTag ......... 2UA0090J48
WorkstationInformation.BiosSerialnumber ..... 2UA0090J48
WorkstationInformation.BiosVersion .......... Hewlett-Packard 786G7 v01.02 10/22/2009
WorkstationInformation.SystemManufacturer ... Hewlett-Packard
WorkstationInformation.ProductName .......... HP Compaq 8000 Elite USDT PC
WorkstationInformation.HarddriveSizeMB ...... 152627
WorkstationInformation.RAM .................. 2052
WorkstationInformation.BootMedia ............ 3
WorkstationInformation.zenPartitionType...... 0x00
10/26/11 10:36:20 -- [RNT] PSI size = 164
10/26/11 10:36:20 -- [RNT] Received PrebootState Information:
Dumping PrebootStateInformation:
PrebootStateInformation.signature ............ ZENPBINF
Structure Version ... 3
Structure Length ... 164
Version ............... 0
Flags ................. 0
State ................. 0
Tree ID ................
Job ID ................
Task ID ................ 0
Task Completion Code ... 0
10/26/11 10:36:20 -- [RNT] Error String:N okt o

10/26/11 10:36:21 -- [RNT] Server GUID is: 560ccfc3e30e05417c772b0c684de12c
10/26/11 10:36:21 -- [RNT] GNT returned 0
10/26/11 10:36:21 -- [RNT] Sending PrebootState Information:
Dumping PrebootStateInformation:
PrebootStateInformation.signature ............ ZENPBINF
Structure Version ... 3
Structure Length ... 164
Version ............... 0
Flags ................. 0
State ................. 0
Tree ID ................
Job ID ................
Task ID ................ 0
Task Completion Code ... 0
10/26/11 10:36:21 -- [RNT] XML Size = 85
10/26/11 10:36:21 -- [RNT] XML is = <ZENworks-Imaging><Type>Reboot-Command</Type><ErrCode>0</ErrCode></ZENworks-Imaging>
10/26/11 10:36:21 -- [PCGNT] done PROXY_CMD_GET_NEXT_STEP
10/26/11 10:36:21 -- [PCC] received PROXY_CMD_CLOSE
10/26/11 10:36:21 -- [PCC] done PROXY_CMD_CLOSE
10/26/11 10:36:21 -- [LC] close connection, 10.20.0.187
10/26/11 10:36:21 -- [ECC] CS

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~
Here is the XML line from one that works:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~
10/25/11 14:54:07 -- [RNT] XML Size = 210
10/25/11 14:54:07 -- [RNT] XML is = <ZENworks-Imaging><Type>Restore-ZENworks-Image</Type><File>C:\Program Files\Novell\ZENworks\work\content-repo\images\8000SFFxpF.zmg</File><ServerIP>10.25.66.95</ServerIP><FileSet>1</FileSet></ZENworks-Imaging>
10/25/11 14:54:07 -- [PCGNT] done PROXY_CMD_GET_NEXT_STEP
10/25/11 14:54:07 -- [PCGI] received PROXY_CMD_GET_IMAGE
10/25/11 14:54:07 -- [PCGI] Image File: C:\Program Files\Novell\ZENworks\work\content-repo\images\8000SFFxpF.zmg
10/25/11 14:54:07 -- [SIF] sending C:\Program Files\Novell\ZENworks\work\content-repo\images\8000SFFxpF.zmg
10/25/11 14:54:07 -- [ZIFO] o 3
10/25/11 14:54:07 -- [SIF] start download



I have deleted and recreated the image bundle and rule with no luck, any ideas?