Hello everyone,
I am in progress to upgrade my Netware 6.5 cluster to OES2 linux. I have test environment with 2-node cluster virtual machines. I have read documentation, and upgraded second Netware node. So far so good. Then I made upgrade of my first Netware node (master eDir replica, mastrer CA, etc), but I have no success - eDir instalation failed. Did i miss something in documentation? What is best practices to upgrade first server?

PKIhealth.log:
Code:
Step 0  Check if this server should be an SDI Key Server.
     Testing for keyfile -- /var/opt/novell/nici/0/nicisdi.key.
     This server does not have any SDI keys on it.
Step 0 succeeded.

Step 1  Verifying the Server's link to the SAS Service Object.
Step 1 failed -601.

Step 2  Verifying the SAS Service Object
PROBLEM: A SAS Service object was not found.
ERROR -672 while trying to create SAS Service object 'SAS Service - N1.vetev'.
PROBLEM: Server 'N1.vetev' does not have Supervisory Entry rights to SAS Service object 'SAS Service - N1.vetev'
ERROR -601 trying to add Supervisory Entry rights for server 'N1.vetev'
PROBLEM: SAS Service object 'SAS Service - N1.vetev' does not have Read All Attribute rights to itself.'
ERROR -601 trying to add Read All Attributes rights to itself
Step 2 failed -601.

Step 3  Verifying the links to the KMOs
ERROR -601 resolving to SAS Service object 'SAS Service - N1.vetev'.
Step 3 failed -601.
ndsd.log:
Code:
Oct 31 16:03:54  Successfully started Novell PKI Services
Oct 31 16:03:54  SecurityInstall: Calling pkiInstallSetIdentity . . .
Oct 31 16:03:54  SecurityInstall: Returned from pkiInstallSetIdentity.
Oct 31 16:03:54  SecurityInstall: Calling pkiInstallsetCRLfile . . .
Oct 31 16:03:54  SecurityInstall: Returned from pkiInstallsetCRLfile.
Oct 31 16:03:54  SecurityInstall: Returned from pkiInstallGetDistributionPointInfo.
Oct 31 16:03:54  SecurityInstall: Error from pkiInstallCreatePKIObjects (ccode = -603; retval = 0).
Configuring Distribution Points for Certificate Revocation List:
Oct 31 16:03:54  An error occurred while configuring product SAS. Error description no such attribute.-603
Oct 31 16:03:54  NDSIInstallDSProduct: Returning -603.
Oct 31 16:03:54  DHModuleInit_dsi: Returning -603.
Certificate was added to keystore
Certificate was added to keystore
Oct 31 16:03:55  Module dsi is not loaded
Now i want to refresh my test cluster nodes from backup images and try to upgrade first Netware node again. Tell me what i did wrong please.

Thank you.