Hi There,

I had a look at what has been already posted but I did not find anything relevant for my issue so here is my Post:

I was hoping to deploy/update Firefox 7.0.1 in two shots:

1. Copy my installation files locally in the user's Temp folderr via "Install Directory" in "Install" tab that contains my setup.bat, a folder where I have Firefox preferences stored and the firefox exe file
2. Lauch the installation via a "Run Script" in "Install" or either "Launch" tab that bakups up the bookmark file in the case of firefox is already installed (which moslty is), uninstall it, install the new version, copy the preference folder in the AllUsers and User profile and finally move back the bookmark file. I launched it from the managed computer. I also tried to copy and paste the script to define my own but nothing worked.

What works is the installation folder but unfortunately the script does not work whereas it works perfectly locally. Our user are local admin but I tested the various ways of running.

I then tried to divide my script into several(5 steps in 5 differents bundle enabled/disabled playing) to see what zen did not like and it seems that xcopy commands are difficult for him. Here are mine:

XCOPY "To_Copy" "%allusersprofile%\Application Data\" /S /E /Y
XCOPY "To_Copy" "%appdata%\" /S /E /Y

I created a bundle for each steps of my installation and what seems to be always a problem is the xcopy. The best I could get is to have one of them working and only the first excecuted one. I played with different kind of delay inside Zen and even in my script with ping command and so on but nothing. As you can imagine I spent several hours to troubleshoot this without reall success.


Am I supposed to play as much as I do to launch simple bat script that works locally? Is there a scripting standard for Zen to excecute them correctly? Or Zen is not made for such things?

Thank you for any clue on this.