If you're using Mac OS X on a 64-bit Mac (so Intel Core 2 Duo or better)
and you get an error trying to install the 64-bit Mac agent

Package intended for 64 bit architecture
Exiting with error code 238.

no you're probably not going mad(!) but will probably find Java is not
installed. 'java -version' will confirm and trigger a download.

You're most likely to see this with Lion (10.7) as by default it doesn't
include Java - it only gets installed if you go download it or trigger a
Java process.

Got caught by this one last night at home with freshly installed Lion.

Bug #732596 logged as installer should check for Java and report a
meaningful error if not!

Novell Knowledge Partner (NKP)

Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.