When updating to the latest ZENworks agents (, suddenly we saw one workstation registered with the same guid as our primary ZENworks server. After this I check the ZCC and see the workstation is now the primary ZENworks server and the original ZENworks server is not registered any more. After this all other agents think this workstation is the new primary ZENworks server.
The only way to fix this is uninstall the client on the new workstation and restore a backup on the ZENworks server.

We tried several things to fix this issue, like running ZISwin and reinstall the workstation, but without any luck, the workstation registers itself as the new ZENworks server.

After this every client needs a zac cc to clear it's cache, but as I understand the problem is still not fixed.

Does anyone have a solution to install the agent without any register issue or to change the guid on the workstation?

Please Help?!


(btw. I'm also not able to unregister the workstation, because it says I cannot unregister an agent on a ZENworks server)