I'm trying to setup a new ZCM 11.1a server in our environment.

Server is an ESXi 4.1 guest running SLES10sp4, fully patched. Nothing else installed/configured on the server, it's just for Zenworks.

The initial installation failed with a problem creating packages, but I continued anyway, thinking that was relatively minor and I could go back and resolve it later. All the services appear to be running, but I know it's broken. Running ZDC 11.1 turns up the following error, which also shows up in various log files. I've tried to reinstall hoping to fix the problem, but it wants to connect to the database, which it can't do. I installed it using an internal CA (logged into the server as root) and internal Sybase database. The database service is running, as well as all the zenworks services.

Here's the output of the ZDC:

+ Starting ZENworks Diagnostic Center.

+ ----------------------------------
System Information:
+ ----------------------------------
OS: SUSE Linux Enterprise Server 10 64 bit
Database: Unknown Database
ZCM Version: 11.1.0

+ Loading configuration.
java.io.FileNotFoundException: /etc/opt/novell/zenworks/datamodel/zdm.xml (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.jav a:106)
at com.novell.zenworks.zdc.config.Configuration.loadD atabaseConfiguration(Configuration.java:368)
at com.novell.zenworks.zdc.config.Configuration.initi alize(Configuration.java:222)
at com.novell.zenworks.zdc.DiagnoseZen.startZDC(Diagn oseZen.java:99)
at com.novell.zenworks.zdc.DiagnoseZen.start(Diagnose Zen.java:64)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.novell.zenworks.zdc.boot.Bootstrap.main(Bootst rap.java:113)

Basically the zdm.xml is missing (which it is). Is there a way to create this manually? I tried doing the install previously and ended up just wiping the guest and rebuilding it (only takes an hour or so) because of all the problems it was having. I can't run the upgrade because it knows ZCM is already installed but it wants to connect to an external database. (probably because it can't connect to the one internally)