Are there any issues in connecting 3.6 SERver VPN to 3.8 Server VPN ?

I'm looking to upgrade 1 server to NW 6.5 and need to upgrade BM 3.6 on
this server first. I just want to make sure that there are no
surprises.

Steve