Can some one tell me the requirements for the Android client?

I have it on one phone, Android version 2.3.4, but it does not show in the market for a 2.1.x phone.

David.