I am trying to make some post-imaging changes and though I'd give the Hardware Rules a go ( which I haven't used for a long, long time .. not in ZCM at least ). I am not getting an error similar to :

http://forums.novell.com/novell/nove...rror-91-a.html

Except for mine doesn't have an error code, it just says "Error: Failed to return a task" when I check for work to do manually ( F9 when running img on the device ). This device has been factory imaged using the image supplied with Zenworks agent installed and zac fsg -d was done before hutdown. I am not sure if that matters or not as I belive h/w rules are supposed to apply to both registered and non-registered devices ?

Anyway, here is a pbserv.log:
Mon Jan 9 18:49:12 2012 -- [LicenseCheck] Checking Imaging License
Mon Jan 9 18:49:12 2012 -- [RNT] Server GUID is: 96cbb868c5389a6370fa25cae0053449
Mon Jan 9 18:49:12 2012 -- [RNT] Imaging License Info: 1
Mon Jan 9 18:49:12 2012 -- [LC] open connection, 10.129.50.10
Mon Jan 9 18:49:12 2012 -- [PCV] received PROXY_CMD_VERSION
Mon Jan 9 18:49:12 2012 -- [HC] versions: 10, 10, 103305
Mon Jan 9 18:49:12 2012 -- [PCV] done PROXY_CMD_VERSION
Mon Jan 9 18:49:12 2012 -- [PCGNT] received PROXY_CMD_GET_NEXT_STEP
Mon Jan 9 18:49:12 2012 -- [RNT] WS GUID = "db6f55286cb56c4f8b4ce1267104188e"
Mon Jan 9 18:49:12 2012 -- [RNT] GWIL = 5176
Mon Jan 9 18:49:12 2012 -- [RNT] Received Workstation Information:
Dumping Workstation Information:
WorkstationInformation.signature ............ ZENWSINF
WorkstationInformation.version .............. 6
WorkstationInformation.length ............... 5176
WorkstationInformation.Chipset .............. Intel(R) Corporation 1204 Mhz
WorkstationInformation.Video ................ Intel Corporation Unknown device 0x0046
WorkstationInformation.Network .............. Intel Corporation Unknown device 0x0082
WorkstationInformation.Soundcard ............ Intel Corporation Unknown device 0x3B56
WorkstationInformation.Diskcontroller ....... IDE
WorkstationInformation.MACAddress............ 20:6a:8a:64:ff:8a
WorkstationInformation.ipAddress ............ 10.129.50.10
WorkstationInformation.BiosAssetTag ......... Base Board Asset Tag
WorkstationInformation.BiosSerialnumber ..... 14704211
WorkstationInformation.BiosVersion .......... INSYDE V1.24 05/06/2011
WorkstationInformation.SystemManufacturer ... Acer
WorkstationInformation.ProductName .......... Aspire One 753
WorkstationInformation.HarddriveSizeMB ...... 305245
WorkstationInformation.RAM .................. 4096
WorkstationInformation.BootMedia ............ 3
WorkstationInformation.zenPartitionType...... 0x00
Mon Jan 9 18:49:12 2012 -- [RNT] PSI size = 164
Mon Jan 9 18:49:12 2012 -- [RNT] Received PrebootState Information:
Dumping PrebootStateInformation:
PrebootStateInformation.signature ............ ZENPBINF
Structure Version ... 3
Structure Length ... 164
Version ............... 0
Flags ................. 0
State ................. 4
Tree ID ................
Job ID ................
Task ID ................ 0
Task Completion Code ... 0
Mon Jan 9 18:49:12 2012 -- [RNT] Error String:Err Fie ortr ak
Mon Jan 9 18:49:12 2012 -- [RNT] Server GUID is: 96cbb868c5389a6370fa25cae0053449
Mon Jan 9 18:49:12 2012 -- [RNT] Error SGNT: 2003
Mon Jan 9 18:49:12 2012 -- [RNT] GNT returned 2003
Mon Jan 9 18:49:12 2012 -- [RNT] Sending PrebootState Information:
Dumping PrebootStateInformation:
PrebootStateInformation.signature ............ ZENPBINF
Structure Version ... 3
Structure Length ... 164
Version ............... 0
Flags ................. 0
State ................. 4
Tree ID ................
Job ID ................
Task ID ................ 0
Task Completion Code ... 0
Mon Jan 9 18:49:12 2012 -- [PCGNT] done PROXY_CMD_GET_NEXT_STEP
Mon Jan 9 18:49:12 2012 -- [PCC] received PROXY_CMD_CLOSE
Mon Jan 9 18:49:12 2012 -- [PCC] done PROXY_CMD_CLOSE
Mon Jan 9 18:49:12 2012 -- [LC] close connection, 10.129.50.10
Mon Jan 9 18:49:12 2012 -- [ECC] CS
Now I wonder what that Error SGNT might mean ..

Originally I wanted to push just a linked application bundle ( a batch script to run ) but eventually tried adding our standard base image to no avail.

When I try to apply the same imaging bundle to a different notebook ( using a different h/w rule ) - clearly using the right ProductName or BiosSerialnumber - it simply returns "No work to do". Which is better than failing to return a task but still .. doesn't do any work, really. Here it is:
Mon Jan 9 19:00:37 2012 -- [LicenseCheck] Checking Imaging License
Mon Jan 9 19:00:37 2012 -- [RNT] Server GUID is: 96cbb868c5389a6370fa25cae0053449
Mon Jan 9 19:00:37 2012 -- [RNT] Imaging License Info: 1
Mon Jan 9 19:00:37 2012 -- [LC] open connection, 10.129.50.11
Mon Jan 9 19:00:37 2012 -- [PCV] received PROXY_CMD_VERSION
Mon Jan 9 19:00:37 2012 -- [HC] versions: 10, 10, 103305
Mon Jan 9 19:00:37 2012 -- [PCV] done PROXY_CMD_VERSION
Mon Jan 9 19:00:37 2012 -- [PCGNT] received PROXY_CMD_GET_NEXT_STEP
Mon Jan 9 19:00:37 2012 -- [RNT] WS GUID = "44398adf69915a4c8de5a15589ffd679"
Mon Jan 9 19:00:37 2012 -- [RNT] GWIL = 5176
Mon Jan 9 19:00:37 2012 -- [RNT] Received Workstation Information:
Dumping Workstation Information:
WorkstationInformation.signature ............ ZENWSINF
WorkstationInformation.version .............. 6
WorkstationInformation.length ............... 5176
WorkstationInformation.Chipset .............. Intel(R) Corporation Pentium M processor 1200 Mhz
WorkstationInformation.Video ................ Intel Corporation Unknown device 0x2A43
WorkstationInformation.Network .............. Intel Corporation Unknown device 0x422C
WorkstationInformation.Soundcard ............ Intel Corporation HD Audio Controller
WorkstationInformation.Diskcontroller ....... IDE
WorkstationInformation.MACAddress............ 60:eb:69:35:5d:2d
WorkstationInformation.ipAddress ............ 10.129.50.11
WorkstationInformation.BiosAssetTag ......... Base Board Asset Tag
WorkstationInformation.BiosSerialnumber ..... 10102849
WorkstationInformation.BiosVersion .......... INSYDE v1.3310 03/25/2010
WorkstationInformation.SystemManufacturer ... Acer
WorkstationInformation.ProductName .......... AO752
WorkstationInformation.HarddriveSizeMB ...... 238475
WorkstationInformation.RAM .................. 2048
WorkstationInformation.BootMedia ............ 3
WorkstationInformation.zenPartitionType...... 0x00
Mon Jan 9 19:00:37 2012 -- [RNT] PSI size = 164
Mon Jan 9 19:00:37 2012 -- [RNT] Received PrebootState Information:
Dumping PrebootStateInformation:
PrebootStateInformation.signature ............ ZENPBINF
Structure Version ... 3
Structure Length ... 164
Version ............... 0
Flags ................. 0
State ................. 0
Tree ID ................ c7ebeac25e25b763ad08e6c18bd67b44
Job ID ................
Task ID ................ 0
Task Completion Code ... 0
Mon Jan 9 19:00:37 2012 -- [RNT] Error String:N okt o
Mon Jan 9 19:00:37 2012 -- [RNT] Server GUID is: 96cbb868c5389a6370fa25cae0053449
Mon Jan 9 19:00:37 2012 -- [RNT] GNT returned 0
Mon Jan 9 19:00:37 2012 -- [RNT] Sending PrebootState Information:
Dumping PrebootStateInformation:
PrebootStateInformation.signature ............ ZENPBINF
Structure Version ... 3
Structure Length ... 164
Version ............... 0
Flags ................. 0
State ................. 0
Tree ID ................ c7ebeac25e25b763ad08e6c18bd67b44
Job ID ................
Task ID ................ 0
Task Completion Code ... 0
Mon Jan 9 19:00:37 2012 -- [RNT] XML Size = 85
Mon Jan 9 19:00:37 2012 -- [RNT] XML is = <ZENworks-Imaging><Type>Reboot-Command</Type><ErrCode>0</ErrCode></ZENworks-Imaging>
Mon Jan 9 19:00:37 2012 -- [PCGNT] done PROXY_CMD_GET_NEXT_STEP
Mon Jan 9 19:00:37 2012 -- [PCC] received PROXY_CMD_CLOSE
Mon Jan 9 19:00:37 2012 -- [PCC] done PROXY_CMD_CLOSE
Mon Jan 9 19:00:37 2012 -- [LC] close connection, 10.129.50.11
Mon Jan 9 19:00:37 2012 -- [ECC] CS
Am I missing something here ?