Whats the version interoperability of BM VPN ?

I seem to recall from example that 3.5 works with 3.6 but will;

3.8 work with 3.7, 3.6, 3.5

3.7 work with 3.6, 3.5 etc ?