We are running DataSync mobilty pack 1.2 579! working fine ...

now our department chief came along with an nokia lumia 800 with windows phone 7.5 (mango).
I was not able to get this work with you datasync.
(the device keeps telling us there is something to do and sync failed. the device is listened at the datasync.)

Do anyone of you use an winphone 7.5 device. is this working with datasync? Do I have to update my datasync?
What version should I use, or should I update using the update-channels.

thanks ahead