We are running NetWare 6.5sp8 in a two node cluster, on HP DL380 G3
servers attached via SCSI to an MSA500. All of the storage is setup as
RAID10. I have been using NSSMU for adding storage to the cluster.

I have an existing 600GB LUN with an existing pool and a couple volumes
on it. I recently needed to add some new disk space to the MSA, with
plans to expand the pool on this cluster.

I added more drives, and after the array successfully expanded I created
two new LUNs (should have probably made this one new LUN - oh well). I
successfully initialized the new LUNs and marked them as "Shareable for

As I prepared to add the new LUNs to the existing pool, I saw that the
pool, and the original LUN that the pool is on, was NOT marked shareable
for clustering. This HAD previously been marked as shareable, and I
have no idea how it became unshared.

When I press F6 to try to re-flag the old LUN as "Shareable for
Clustering" again, I get the following error code and message

20896 - cluster sharing violation

This looks similar to the issue mentioned in TID 3942011, but that seems
specific to NetWare 6.5 SP6, and as I mentioned we are on SP8 which has
a newer MM.NLM.

I have tried re-sharing the LUN from each cluster node, after restarting
both cluster nodes, and from one node while the other node was off-line.
None of these have worked, and I receive the same error.

I'm leary of adding the new LUNs to the pool while the old LUN is marked
as not shareable. It's possible it will work without issue, or that it
will just give me an error if I try, but I didn't want to lose data or
possibly put the cluster in a weird state that may lead to data
corruption down the road.

Any thoughts?