We are currently running Mobility 1.1 Build 315. I noticed the current version is 1.2.1 Build 730. Can I upgrade straight to 730 with no ill-effect, or will I need to install subsequent updates prior to reaching that version? Thanks!