Is anybody else seeing this message while updating oes2 sp3 sles10 sp4?.....

Download failed: Download failed: (https://nu.novell.com/repo/$RCE/SLES10-SP4-Updates/sles-10-x86_64/rpm/x86_64/apache2-2.2.3-16.44.1.x86_64.rpm) The remote server returned an error: (503) Service Unavailable.

I will probably try later but just wondered if anyone else was seeing it.