I'm trying to run and getting the error quoted
/usr/bin/zman satellite-server-add-imagingrole /devices/servers/bnebuild1 --Content-Replication-Schedule=Satellite-Content-Replication-Schedule.xml --proxydhcp=start

Error:Error in XML file "/root/Satellite-Content-Replication-Schedule.xml" . See zman log for more information.


ERROR: 45
my xml sheet was created by exporting the schedule from a working server and then removing the UniqueID (have tried it with the UniqueID too - same result)
zman satellite-server-export-content-replication-setting-schedule /devices/servers/adlbuild1 Imaging --scheduleFileName=Satellite-Content-Replication-Schedule.xml

cat Satellite-Content-Replication-Schedule.xml
<Schedule xmlns="http://www.novell.com/ZENworks/v1.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.novell.com/ZENworks/v1.0">
<IntervalSchedule>
<RepeatFrequency Months="0" Weeks="0" Days="1" Hours="0" Minutes="0" Seconds="0" />
<StartTime Hour="1" Minute="0" Second="0" />
<StartDate Year="2012" Month="3" DayOfMonth="20" />
<UseGMT>false</UseGMT>
<RandomDispatch>false</RandomDispatch>
<PastDue>false</PastDue>
<UniqueID></UniqueID>
</IntervalSchedule>
</Schedule>
LOG:
[DEBUG] [3/19/12 11:44:34 AM] [] [ZMan] [] [Command completed in 18469 ms] [] []
[DEBUG] [3/19/12 11:52:08 AM] [] [ZMan] [] [Command: satellite-server-add-imagingrole /devices/servers/bnebuild1 --Content-Replication-Schedule=Satellite-Content-Replication-Schedule.xml --proxydhcp=start --TerminalDevice=/dev/pts/0 --ScreenDimension=50 170 ] [] []
[DEBUG] [3/19/12 11:52:09 AM] [] [ZMan] [] [Checking if we need to cache licenses] [] []
[DEBUG] [3/19/12 11:52:09 AM] [] [ZMan] [] [Should recache: false] [] []
[DEBUG] [3/19/12 11:52:27 AM] [] [ZMan] [] [Error:Error in XML file "/root/Satellite-Content-Replication-Schedule.xml" . See zman log for more information.] [] []
[DEBUG] [3/19/12 11:52:27 AM] [] [ZMan] [] [Command failed (partially or totally)] [] []
[DEBUG] [3/19/12 11:52:27 AM] [] [ZMan] [] [Command completed in 18636 ms] [] []

any one know what might need to be added or removed ?

i have successfully got the following working, just need this too fly and i've got a fully working auto install.
/usr/bin/zman satellite-server-create /devices/servers/"$1"build1 Authentication,Collection,Content /devices/servers/crt-zcm1
/usr/bin/zman satellite-server-configure-authentication-user-source /devices/servers/"$1"build1 TREE_NAME Connection_name