I am starting to have problem connecting new devices to my datasync server. The only thing these devices have in common is that they have iOS 5.1. This problem seems to only appear when the device is being added to the datasync server. If the device has already been added and then it is updated to 5.1, the device will continue to sync fine. When I get a device that has 5.1 on it, I get Unable to verify connection every time I try. Has anybody else seen this? Or should I open a ticket with Novell?