Our Service Desk is trying to send email to "admin@mycompany.com" I'm sure it is right in front of my face, but could some one point me to this setting.

Thanks,
David.