I've just upgraded my 'first' Primary ZCM server from 11.1a to 11.2. Physical Windows 2008 (non-R2) server. External (MS-SQL) database and server upgraded perfectly without errors.
Then I go to upgrade the 'second' Primary server (Windows 2008 R2 on hosted VMware 4.1. ZENworks is installed in C:\Novell\Novell\ZENworks). It fails horribly!

Looking at the system-update.log, the upgrade seems to think it's a Linux box!
The log file starts off fine...
Code:
DEBUG;;;Running prerequisite checks
DEBUG;;;Checking for Windows 2000...
DEBUG;;;Checking for Windows Installer 3.1...
DEBUG;;;Checking for .NET 3.5 SP1...
but then later we get
Code:
DEBUG;;;Attempting to stop service: /etc/init.d/novell-tftp
DEBUG;;;Unable to create service /etc/init.d/novell-tftp. Service /etc/init.d/novell-tftp was not found on computer '.'.
DEBUG;;;Attempting to stop service: /etc/init.d/novell-zmgprebootpolicy
DEBUG;;;Unable to create service /etc/init.d/novell-zmgprebootpolicy. Service /etc/init.d/novell-zmgprebootpolicy was not found on computer '.'.
etc, and looking on the server's C: drive we have /etc and /opt file structures created.

After it 'finishes' and restarts, the server agent reports version 11.2, but it's unregistered and no longer part of the zone.
The zone shows the server as 'installing update' but shows no agent version nor audit data against the server.

I'm thinking the affected server is effectively toast and wondering the best way to remove it cleanly from the zone (ZENworksUninstall.exe? zman sd? delete from heirachy? etc...)

Any thoughts welcome


Matthew