I have the following strange problem on an OES11 server, which was
installed new. If novell-nss is started during bootup it brings the
server into a totally unreponsive state - cpu utilization maxxes out
and neither keyboard/mouse nor any network connection (ssh, http, ping)
is available. The server can only be power cycled a shutdown is
impossible even if you wait for over an hour. That is independent of
the time during bootup, when novell-nss is started - I even put it to
the absolute end of init scripts, that did not alter the behaviour. But
if I disable novell-nss during the init phase and start it immediately
after runlevel 3 is reached, it starts fine within seconds - mounts all
volumes and there is no problem at all.

If the server hangs the last log lines are as follows:
Apr 6 22:29:34 SERV-3-TWB nss: Starting Novell Storage Services (NSS)
Apr 6 22:29:34 SERV-3-TWB nss: Start up eDir and LUM
Apr 6 22:29:37 SERV-3-TWB nss: Start up NSS modules
Apr 6 22:29:37 SERV-3-TWB kernel: [ 86.489321] NWRAID1: Initializing
Apr 6 22:29:37 SERV-3-TWB kernel: [ 86.568388] NWRAID: Initializing
Apr 6 22:29:38 SERV-3-TWB kernel: [ 86.614847] NWRAID5: Initializing
Apr 6 22:29:39 SERV-3-TWB kernel: [ 87.832732] libnss loaded
Apr 6 22:29:39 SERV-3-TWB kernel: [ 87.832736] Number RTSC counts in
a microsecond is 2000
Apr 6 22:29:39 SERV-3-TWB kernel: [ 88.407579] nsslnxlib loading...
Apr 6 22:29:39 SERV-3-TWB kernel: [ 88.519192] Opening Unicode table
437
Apr 6 22:29:39 SERV-3-TWB kernel: [ 88.519925] Open Unicode table
status 0
Apr 6 22:29:39 SERV-3-TWB kernel: [ 88.519927] Loaded host locale
Apr 6 22:29:39 SERV-3-TWB kernel: [ 88.519929] nsslnxlib loaded
Apr 6 22:29:40 SERV-3-TWB kernel: [ 88.953642] library loaded
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.400199]
NSS::/usr/src/packages/BUILD/nss/modules-build/nss/nssLKM.c[254]
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.400204]
NSS::/usr/src/packages/BUILD/nss/modules-build/nss/nssLKM.c[256]
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.400205] register
NSS_ConsoleCmdParser
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.400207] ParseNSSConfigFile
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.532639] now open config
files: /etc/opt/novell/nss/nssstart.cfg
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.534540] NSSGlobal_Startup
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.534554] Importing LibC
Unicode support
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.535980] Opening Unicode table
1
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.556939] Open Unicode table
status 0
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.561242] FDAT_UnitTest(start)
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.561243] This test assumes
USA locale.
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.561249] Nov 1, 2000 11:35:28
am
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.561252] May 14, 2001
3:55:44 pm
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.561365] FDAT_UnitTest did not
detect any errors in 116 tests.
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.561366] FDAT_UnitTest(end)
Apr 6 22:29:40 SERV-3-TWB kernel: [ 89.561369]
NSS::/usr/src/packages/BUILD/nss/modules-build/nss/nssLKM.c[336]
Apr 6 22:29:41 SERV-3-TWB kernel: [ 89.906910] ndpmod:misc_register
called at tv_sec:1333744181 tv_usec:314163 retval = 0 success
Apr 6 22:29:41 SERV-3-TWB kernel: [ 89.976292] Module ndpmod
installed

And after that nothing happens anymore.

Seems to be similar to KB 7004877 with the difference, that this is
OES11 and SLES11 does not have a /etc/sysconfig/udev file anymore.


--
W. Prindl