Hello,

I have been trying to update my servers with new ZCM 11 SP2 fix but keep getting the same error.
Details on network
4 VM servers
- SLES 10 SP4
- all running ZCM 11 SP2

Excerpt from Loader-Messages.log

[DEBUG] [4/16/12 3:50:58 PM] [] [Loader.SystemUpdateModule] [1413] [] [FINE: Starting runUpdatePatchAction, data: <PatchContentData><UpdateGUID>5011020000fc50000000 002012030723</UpdateGUID><BaseURL>file:///tmp/ZCMTID700090/ZCM_11.2.0_20120409_754483.zip</BaseURL><PatchEntry ContentID="15ef3f90084888b1617e37dbb9174c36" FilePath="file:///tmp/ZCMTID700090/ZCM_11.2.0_20120409_754483.zip/msi/novell-zenworks-actionhandlers-11.2.0.16828.msi" /></PatchContentData>] [] []
[DEBUG] [4/16/12 3:50:58 PM] [] [Loader.QueueRunner] [1398] [] [Passing the action ID: 31298, Type:Location.Configuration.Module to Handler: com.novell.zenworks.locations.loader.modules.Locat ionConfigurationModule] [] []
[DEBUG] [4/16/12 3:50:58 PM] [] [Loader.SystemUpdateModule] [1413] [] [FINE: Updating content 15ef3f90084888b1617e37dbb9174c36 with msi/novell-zenworks-actionhandlers-11.2.0.16828.msi] [] []
[DEBUG] [4/16/12 3:50:58 PM] [] [Loader.SystemUpdateModule] [1413] [] [FINE: Existing content file: /var/opt/novell/zenworks/content-repo/system-update/5011020000fc50000000002012030723/msi/novell-zenworks-actionhandlers-11.2.0.16054.msi] [] []
[DEBUG] [4/16/12 3:50:58 PM] [] [Loader.SystemUpdateModule] [1413] [] [FINE: New content file: /var/opt/novell/zenworks/content-repo/system-update/5011020000fc50000000002012030723/msi/novell-zenworks-actionhandlers-11.2.0.16828.msi] [] []
[DEBUG] [4/16/12 3:50:58 PM] [] [Loader.SystemUpdateModule] [1413] [] [FINE: Checksum of existing content file: a0842e54b7409d1120039117d6221b2776f2d7a1c7164996e3 f65a0331a42ac8] [] []
[DEBUG] [4/16/12 3:50:58 PM] [] [Loader.SystemUpdateModule] [1413] [] [FINE: Checksum of patch content file: c5778e472571e9ff80419439b6937a21c3a6a6c62b910bdacc c75ed384f74357] [] []
[ERROR] [4/16/12 3:50:58 PM] [] [Loader.SystemUpdateModule] [1413] [Error occurred while trying to patch the update] [Error occurred while trying to patch the update] [java.io.FileNotFoundException: /var/opt/novell/zenworks/content-repo/system-update/5011020000fc50000000002012030723/msi/novell-zenworks-actionhandlers-11.2.0.16828.msidownloading (Permission denied)[/B]
at java.io.FileOutputStream.open(Native Method)
at java.io.FileOutputStream.<init>(FileOutputStream.j ava:179)
at java.io.FileOutputStream.<init>(FileOutputStream.j ava:131)
at com.novell.zenworks.systemupdate.ZipHelper.getUrlA sFile(ZipHelper.java:173)
at com.novell.zenworks.loader.modules.queue.handlers. PatchUpdateHandler.runUpdatePatchAction(PatchUpdat eHandler.java:188)
at com.novell.zenworks.loader.modules.queue.handlers. PatchUpdateHandler.processAction(PatchUpdateHandle r.java:56)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.processAction(QueueThreadWorker.ja va:212)
at com.novell.zenworks.loader.modules.queue.runner.Qu eueThreadWorker.run(QueueThreadWorker.java:143)
at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)

I followed the installation steps that come out with the update, but can not get past this point. I have changed the permissions on the extracted folder to root and run the update as root also. I am rather raw when it comes to Linux, so if I have missed something, I would appreciate some guidance.

On a positive note, I update the servers from 10.3.3 to 11.2 about two weeks ago. The updates went flawless and have helped with slow login times. My supervisor went from over a few minutes at login to just over 50 seconds.

Thanks for any help and if you need more info for diagnosis, let me know,

TimO