I am running discover applicable updates on my Windows 7 64 bit machines and when I look at how its running in the progress, it calls up failure and I did an in depth look at the logs and the following show up.


[DEBUG] [05/08/2012 13:28:19.022] [1452] [ZenworksWindowsService] [41] [fleminsa] [BundleManager] [] [Finished Process Action for Item: Discover Applicable Updates Windows-x86_64-en-WIN7sp1 Action: LAUNCH Result: False] [] []
[DEBUG] [05/08/2012 13:28:19.039] [1452] [ZenworksWindowsService] [41] [] [BundleManager] [] [Error Processing Bundle Action for bundle: Discover Applicable Updates Windows-x86_64-en-WIN7sp1] [] []
[DEBUG] [05/08/2012 13:28:19.039] [1452] [ZenworksWindowsService] [41] [] [BundleManager] [] [Error is: ] [] []
[DEBUG] [05/08/2012 13:28:19.040] [1452] [ZenworksWindowsService] [41] [fleminsa] [BundleManager] [] [Got exception while processiong the action set - Exception of type 'Novell.Zenworks.AppModule.LaunchException' was thrown.
at Novell.Zenworks.AppModule.AppActionItem.ProcessAct ion(APP_ACTION launchType, ActionContext context, ActionSetResult previousResults)
at Novell.Zenworks.AppModule.AppActionItem.ProcessHan dledAction(APP_ACTION launchType, ActionContext context, ActionSetResult previousResults) ] [] []
[DEBUG] [05/08/2012 13:28:19.040] [1452] [ZenworksWindowsService] [41] [fleminsa] [BundleManager] [] [The launch exception reason is ACTION_SET_FAILURE] [] []
[ERROR] [05/08/2012 13:28:19.040] [1452] [ZenworksWindowsService] [41] [fleminsa] [BundleManager] [Analyze failed to launch.] [] [] [8e1ed18331494d2baa371782c6c40d3d]
[DEBUG] [05/08/2012 13:28:19.043] [1452] [ZenworksWindowsService] [41] [] [BundleManager] [] [!!!!! Failure processing scheduled item !!!!!] [] []


I have uninstalled, reinstalled the ZCM agent and I have unregistered and re registered the machine.

Anybody have any ideas?