My customer has been consistently unable to run Cluster Reports in iManager on either the primary eDirectory sever or backup eDirectory server. When trying to run a report on the first cluster they get this error:

(stack trace)
Exception Stack Trace

java.lang.Exception: Bad XML found during parsing.
at com.novell.ncs.gadgets.NCSMgmt.NCSReport.getNCSRep ort(NCSReport.java:962)
at com.novell.ncs.gadgets.NCSMgmt.NCSReport.buildMain PageXML(NCSReport.java:144)
at com.novell.ncs.gadgets.NCSMgmt.NCSMainMgmt.execute (NCSMainMgmt.java:428)
at com.novell.emframe.dev.Task.execute(Task.java:505)
at com.novell.nps.gadgetManager.BaseGadgetInstance.pr ocessRequest(BaseGadgetInstance.java:858)
at com.novell.nps.gadgetManager.BaseGadgetInstance.ha ndleAction(BaseGadgetInstance.java:2384)
at com.novell.nps.gadgetManager.GadgetManager.process InstanceRequest(GadgetManager.java:1606)
at com.novell.nps.gadgetManager.GadgetManager.process ServiceRequest(GadgetManager.java:1062)
at com.novell.nps.PortalServlet.handleFrameService(Po rtalServlet.java:505)
at com.novell.nps.PortalServlet.processRequest(Portal Servlet.java:373)
at com.novell.nps.PortalServlet.doPost(PortalServlet. java:279)
at com.novell.nps.PortalServlet.doGet(PortalServlet.j ava:262)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:743)
at com.novell.emframe.fw.servlet.AuthenticatorServlet .service(AuthenticatorServlet.java:332)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:856)
at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:269)
at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:188)
at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:172)
at org.apache.catalina.authenticator.AuthenticatorBas e.invoke(AuthenticatorBase.java:530)
at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:117)
at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:108)
at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:174)
at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyo teHandler.java:200)
at org.apache.jk.common.HandlerRequest.invoke(Handler Request.java:291)
at org.apache.jk.common.ChannelSocket.invoke(ChannelS ocket.java:775)
at org.apache.jk.common.ChannelSocket.processConnecti on(ChannelSocket.java:704)
at org.apache.jk.common.ChannelSocket$SocketConnectio n.runIt(ChannelSocket.java:897)
at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:689)
at java.lang.Thread.run(Thread.java:811)

Any idea what might cause this, or more importantly, how to fix this?

Thank you,