Hello all,

I have machines running the 10.2.2 client that suddenly stop submitting inventory with a 10.3.1 server. It seems that it doesn't generate the xml files anymore. While reading the colw32.log, it seems that the process stops after these lines:

[20120606 21:17:22] exiting ReaperTestList::ExecAllTests()
[20120606 21:17:22] WriteTempFileContents for auprinter.dat
[20120606 21:17:22] ZenworksTempFile: C:\Program Files\Novell\ZENworks\work\inventory\temp\auprinte r.dat
[20120606 21:17:22] hex data: 53 41 44 54 40 00 04 00 01 00 FF FF FF FF 33 00 00 00 50 72 69 6E 74 65 72 20 44 69 73 63 6F 76 65 72 79 5B 41 74 74 72 69 62 75 74 65 73 3A 75 6C 5D 50 6F 72 74 7C 4E 61 6D 65 7C 44 72 69 76 65 72 7C 49 50 20 41 64 64 72 65 73 73 00
[20120606 21:17:22] WriteTempFileContents for loginname.dat
[20120606 21:17:22] ZenworksTempFile: C:\Program Files\Novell\ZENworks\work\inventory\temp\loginnam e.dat
[20120606 21:17:22] hex data: 07 00 00 00 69 6D 61 67 69 6E 67
[20120606 21:17:22] auprinter mode: no reconcile, no wif
[20120606 21:17:22] COLLECT.CPP before if (FALSE == bConnInfo && FALSE == bAuprinter)
[20120606 21:17:22] COLLECT.CPP before wrapup_collector_main:

From there it seems that colw32.exe hangs.

I can call colw32.exe from the command line and it'll generate the xml files and upload an inventory to the server.

Doing an upgrade to a newer version of the client at this point is not possible because the newer versions break a bunch of in house applications. Reinstalling the agent sometimes fixes it but it's not a practical solution.

Is there a tool out there to check up on the agent? Any suggestions for a fix?