Hi guys,

I have been working closely with nob1983 with my windows 7 conversion and so far everything has worked great except for a few things. I cant thank him enough for the help he has given me. Awesome guy! I learned a ton because of him. Im sure nob1983 has other things to do, so i figured i would post and get other peoples feed back and give him a bit of a break (im sure he is tired of my emails lol )

So, the issues that remain are the following:

1. My base image has only the Novell client installed. Because of this it breaks the auto login i have setup in my unattend.xml file. I get an error everytime just before the login window pops up that says "local user account is invalid". I click ok then i can login manually as administrator and the rest the boot process can continue. nob1983 mentioned something about installing the novell client using a response file, but i havent been able to find anything about this online. I did however find that it is possible to setup an unattend install for novell client 2 which i found here Silent/Unattended Uninstall the Novell Client for Windows 33
If it is something as simple as setting up my unattend.txt file then setting up another powershell script that installs the novell client before my zcm11 agent then im all for it, i would just need help writing such a script. If any one can suggest a script to use in conjunction with the powershell scripts i pasted below, please share.

2. I have had no luck getting my image to successfully join our Workgroup. I have tried all of the following lines in my unattend.xml file but with no success. Can anyone shed some light as to what im doing wrong with this?
<JoinWorkgroup>LIFESPACE</JoinWorkgroup>
<JoinWorkgroup>%LIFESPACE%</JoinWorkgroup>
<JoinWorkgroup>%Please select a workgroup{LIFESPACE}%</JoinWorkgroup>

3. On the first full boot to the desktop, The network location windows opens asking if the computer is connected to a Home, Work, or Other network even though i have this in my unattend.xml file
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Work</NetworkLocation>
<ProtectYourPC>3</ProtectYourPC>
</OOBE>
any ideas?

Please let me know what you guys think. any help is much appreciated.


Pasted below is my fulll unattend.xml file and below that are the scripts i use for my add-on images for driver installs and zcm agent install. Any help would be appreciated. Cheers!
unattend.xml file
Code:
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <servicing>
        <package action="configure" permanence="permanent">
            <assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.1.7601.17514" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="" />
            <selection name="TabletPCOC" state="true" />
            <selection name="WindowsGadgetPlatform" state="false" />
        </package>
    </servicing>
    <settings pass="offlineServicing">
        <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <EnableLUA>false</EnableLUA>
        </component>
    </settings>
    <settings pass="generalize">
        <component name="Microsoft-Windows-Security-SPP" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SkipRearm>1</SkipRearm>
        </component>
    </settings>
    <settings pass="specialize">
        <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SkipAutoActivation>true</SkipAutoActivation>
        </component>
        <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <RunSynchronous>
                <RunSynchronousCommand wcm:action="add">
                    <Order>1</Order>
                    <Path>Net user administrator /active:yes</Path>
                </RunSynchronousCommand>
            </RunSynchronous>
        </component>
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <TimeZone>Central Standard Time</TimeZone>
            <CopyProfile>true</CopyProfile>
        </component>
        <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <Identification>
                <JoinWorkgroup>%Please select a workgroup to join{LIFESPACE}%</JoinWorkgroup>
            </Identification>
        </component>
    </settings>
    <settings pass="oobeSystem">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <AutoLogon>
                <Password>
                    <Value>***********</Value>
                    <PlainText>true</PlainText>
                </Password>
                <Enabled>true</Enabled>
                <LogonCount>3</LogonCount>
                <Username>administrator</Username>
            </AutoLogon>
            <FirstLogonCommands>
                <SynchronousCommand wcm:action="add">
                    <Order>1</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                    <CommandLine>cscript //b C:\windows\system32\slmgr.vbs /ipk</CommandLine>
                </SynchronousCommand>
                <SynchronousCommand wcm:action="add">
                    <Order>2</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                    <CommandLine>%SystemRoot%\system32\WindowsPowerShell\v1.0\powershell.exe -Command &quot;&amp;{set-executionpolicy RemoteSigned -Force}&quot;</CommandLine>
                </SynchronousCommand>
                <SynchronousCommand wcm:action="add">
                    <Order>3</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                    <CommandLine>C:\Sysprep\Drivers\DPINST.exe /q</CommandLine>
                </SynchronousCommand>
                <SynchronousCommand wcm:action="add">
                    <Order>4</Order>
                    <RequiresUserInput>false</RequiresUserInput>
                    <CommandLine>%SystemRoot%\system32\WindowsPowerShell\v1.0\powershell.exe &quot;c:\windows\oem\setup\Win7Image-Script1.ps1&quot;</CommandLine>
                </SynchronousCommand>
            </FirstLogonCommands>
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
                <NetworkLocation>Work</NetworkLocation>
                <ProtectYourPC>3</ProtectYourPC>
            </OOBE>
            <UserAccounts>
                <AdministratorPassword>
                    <Value>*************</Value>
                    <PlainText>true</PlainText>
                </AdministratorPassword>
                <LocalAccounts>
                    <LocalAccount wcm:action="add">
                        <Password>
                            <Value>************</Value>
                            <PlainText>true</PlainText>
                        </Password>
                        <Description>administrator</Description>
                        <DisplayName>administrator</DisplayName>
                        <Group>administrators</Group>
                        <Name>administrator</Name>
                    </LocalAccount>
                </LocalAccounts>
            </UserAccounts>
            <RegisteredOrganization>Lifespace Communities Inc.</RegisteredOrganization>
            <RegisteredOwner>Lifespace</RegisteredOwner>
            <TimeZone>Central Standard Time</TimeZone>
            <Display>
                <HorizontalResolution>1024</HorizontalResolution>
                <RefreshRate>60</RefreshRate>
                <VerticalResolution>768</VerticalResolution>
                <ColorDepth>32</ColorDepth>
            </Display>
        </component>
        <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-us</InputLocale>
            <SystemLocale>en-us</SystemLocale>
            <UILanguage>en-us</UILanguage>
            <UserLocale>en-us</UserLocale>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="catalog:c:/users/tbattista/desktop/win7 pro/gsp1rmcprvol_en_dvd/sources/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>
Win7image-Script1.ps1
Code:
Write-Host "Disabling LUA in regsitry..."
Set-Location -Path 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System'
Set-ItemProperty -Path . -Name EnableLUA -Value 0

Write-Host "Setting Registry Commands for Next Reboot..."
Set-Location -Path 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce'
Set-ItemProperty -Path . -Name final -Value "C:\WINDOWS\SYSTEM32\WindowsPowershell\v1.0\powershell.exe C:\Windows\OEM\SETUP\Win7Image-Script2.ps1"

Write-Host "Rebooting..."
Restart-Computer

Win7image-Script2.ps1
Code:
Write-Host "Running DPINST to check for additional devices..."

$OSArch = (Get-WMIObject Win32_OperatingSystem).OSArchitecture

$DPInstParams = "/q"

if ($OSArch -match "32-bit") { $DPInstCommand = "C:\Windows\OEM\SETUP\DRIVERS\DPINST.exe" }

$process = [Diagnostics.Process]::Start($DPInstCommand,$DPInstParams)
$process.WaitForExit()

#Read-Host 'Please press ENTER' | Out-Null

Write-Host "Setting Registry Commands for Next Reboot..."
Set-Location -Path 'HKLM:\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce'
Set-ItemProperty -Path . -Name final -Value "C:\WINDOWS\SYSTEM32\WindowsPowershell\v1.0\powershell.exe C:\Windows\OEM\SETUP\Win7Image-Script3.ps1"

Write-Host "Rebooting..."
Restart-Computer


Win7image-Script3.ps1
Code:
Write-Host "Installing ZCM Agent..."

$AgentCommand = "C:\Windows\OEM\SETUP\PreAgentPkg_AgentComplete.exe"
$AgentParams = "-q"

$process = [Diagnostics.Process]::Start($AgentCommand,$AgentParams)
$process.WaitForExit()