When updating encrypted devices to 11.2.1 I get a failure on the install of
'novell-zenworks-fde-sec-11.2.1.221.x86_64.msi'. The
'novell-zenworks-fde-sec-11.2.1.221.x86_64.msi.log' shows the following.

MSI (s) (E00) [07:28:58:219]: Doing action: Error_NeedPassword
Action ended 7:28:58: FSE_MSI_Branding. Return value 1.
Action start 7:28:58: Error_NeedPassword.
MSI (s) (E00) [07:28:58:220]: Product: Novell Full Disk Encryption --
Please enter the administration password via the property ADMINPWD or
UPGDSCRIPT. The upgrade procedure will now abort.

Please enter the administration password via the property ADMINPWD or
UPGDSCRIPT. The upgrade procedure will now abort.
Action ended 7:28:58: Error_NeedPassword. Return value 3.
Action ended 7:28:58: INSTALL. Return value 3.

(Removed some properties log stuff)

MSI (s) (E00) [07:28:58:230]: Note: 1: 1708
MSI (s) (E00) [07:28:58:230]: Product: Novell Full Disk Encryption --
Installation failed.

MSI (s) (E00) [07:28:58:230]: Windows Installer installed the product.
Product Name: Novell Full Disk Encryption. Product Version: 9.6.3.4000.
Product Language: 1033. Manufacturer: SECUDE AG. Installation success or
error status: 1603.

From this info I am guessing the installer is not being passed the admin
password. After the failure I can go back run the msi, enter the admin
password from the 'Emergency Recovery' tab of the device from ZCC and the
install complete correctly.

Server - ZCM 11.2.1 and Internal Database on Win2008R2x64
Client - ZCM 11.2.1 w/MU2 on Win7SP1x64

Jim Koerner