I have a Windows XP SP3 box which I was using as a satellite configured with all roles. I removed the satellite role in zenworks then tried to uninstall the agent from the box. It would not uninstall correctly so I used the Zen 11 agent cleanup utility and everything appeared to be gone. I would like to install the agent on the box again as it is a new version, 11.2.1 and the agent installs correctly however the agent is not attatched to the zone and all of the agent properties show up like so....

ZENworks Adaptive Agent Properties
Property Value
Device Address: Device_IP
Device Name: Device_Name
Configuration Location: Device_Location
Device State: Device_State
Last Contact with Server: Most_Recent_Refresh
Next Contact with Server: Next_Refresh
Primary User: Primary_User
ZENworks Adaptive Agent Version: Zenworks_Version

ZENworks Server Properties
Property Value
Management Zone: Zone_Name
Server DNS: Server_DNS
Server Address: Server_IP

I tried manually using the ZAC commands such as "zac reg -g http://zenworks" however the commands do not even exist. I have tried installing the agent from a different zenworks server as well as a full package install with .net framework but I am having no luck. Once installed the only way to get rid of the agent to reinstall is to use the utility. Add remove programs just error's as well. I do not want to format/reinstall =(. Any help would be appreciated. Thanks.