Migration is from a 6.5 SP8 server in AL_TREE (NW) to an OES11 server in AG_TREE.

Initially tried the Windows based migration tool which would run, but fail to restore trustees:

Wed Jun 13 11:00:41 2012

Trustee CN=connyw.OU=Personal.O=AL was not restored for /media/nss/PERS/

personal/connyw, because the trustee IDs are different.

I was informed that the Wibndows based tool was deprecated and so we tried using the Linux-based one. This one also runs fine as long as we only transfer files. When we try copying trustees it fails. I would love to open an incident, but customer is academic.

The utility errors out and refers to the logs and they say:

2012-08-01 09:15:44,354 DEBUG - executing command /opt/novell/migration/sbin/migmatchup --source-server 10.0.0.2 --destination-server 192.168.226.100 --destination-ldap-container "ou=al,ou=kansli,ou=users,o=ag" "/var/opt/novell/migration/NewProj4/fs/AnnaL_mls.yaml" --progress --progress-interval 1 --source-ldap-port 636 --destination-ldap-port 636
2012-08-01 09:15:44,354 DEBUG - FileName/var/opt/novell/migration/NewProj4/fs/AnnaL_migmatchup.yaml
2012-08-01 09:15:44,359 DEBUG - MigrationProcess:ReadStdErr:run() in the run method
2012-08-01 09:15:44,359 DEBUG - MigrationProcess:ReadStdOut:run() in the run method
2012-08-01 09:15:44,478 DEBUG - 1>
2012-08-01 09:15:44,480 DEBUG - 2> Fatal: Caught exception: syntax error on line 3, col 0: `- file: 'VOL1:KANSLI/PRIVAT/AnnaL/''
2012-08-01 09:15:44,480 DEBUG - 2> Backtrace:
2012-08-01 09:15:44,480 DEBUG - 2> /usr/lib64/ruby/1.8/yaml.rb:217:in `load_documents'
2012-08-01 09:15:44,480 DEBUG - 2> /usr/lib64/ruby/1.8/yaml.rb:217:in `each_document'
2012-08-01 09:15:44,480 DEBUG - 2> /usr/lib64/ruby/1.8/yaml.rb:232:in `load_documents'
2012-08-01 09:15:44,480 DEBUG - 2> /opt/novell/migration/sbin/migmatchup:284:in `main'
2012-08-01 09:15:44,480 DEBUG - 2> /opt/novell/migration/sbin/migmatchup:411
2012-08-01 09:15:44,480 DEBUG - 2>
2012-08-01 09:15:44,480 DEBUG - MigrationProcess:Cleanup() called: migmatchup
2012-08-01 09:15:44,480 DEBUG - After cleanUp() .. this.enablePID= false this.pID = 0
2012-08-01 09:15:44,480 DEBUG - MigrationProcess:ExecuteProcess() returning 1
2012-08-01 09:15:44,480 DEBUG - MigController:isMigrationRunning: start
2012-08-01 09:15:44,480 DEBUG - MigController:isMigrationRunning: retval false
2012-08-01 09:15:44,480 DEBUG - FSMigTool:executeMigmatchupCommand() returnVal -1
2012-08-01 09:15:44,480 DEBUG - FSMigTool:executePhase() returnVal -1
2012-08-01 09:15:44,480 DEBUG - FSPlugin:migmatchup() return value -1
2012-08-01 09:15:44,481 DEBUG - FileSystemDesign:matchUsrActionPerformed() Error executing migmatchup commands!!

Any ideas? In case someone from Novell wants to take a peek, then logs are uploaded to the Navell ftp server as ag_20120806_miglog.tar.gz

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms