Hi,

I'm upgrading a 3 node oes2sp3 cluster to oes11 (not in-place. Fresh install that replaces old node) and as I patch it (zypper -t, etc...) I get the following:

#####
Problem: yast2-novell-schematool-2.13.2-4.360.noarch requires novell-NDSbase, but this requirement cannot be provided
deleted providers: novell-NDSbase-8.8.6.4-3.15.x86_64
uninstallable providers: novell-NDSbase-8.8.6.5-3.29.x86_64[nu_novell_com:OES11-Updates]
novell-NDSbase-8.8.6.6-1.1.x86_64[nu_novell_com:OES11-Updates]
Solution 1: Following actions will be done:
deinstallation of yast2-novell-schematool-2.13.2-4.360.noarch
deinstallation of novell-NDSbase-8.8.6.4-3.15.x86_64
deinstallation of novell-imanager-2.7.4.3-3.73.noarch
deinstallation of novell-plugin-afp-1.1.0-9.68.x86_64
deinstallation of novell-plugin-arkmanager-3.3.0-2.155.x86_64
deinstallation of novell-plugin-backup-restore-2.7-56.331.x86_64
deinstallation of novell-plugin-base-2.7.4.3-3.73.noarch
deinstallation of novell-plugin-case-sensitive-password-2.7-56.222.x86_64
deinstallation of novell-plugin-cifs-2.0.2-3.129.noarch
deinstallation of novell-plugin-dfs-1.0.2-4.127.x86_64
deinstallation of novell-plugin-dhcp-2.0.0-6.151.x86_64
deinstallation of novell-plugin-dns-2.0.0-6.124.x86_64
deinstallation of novell-plugin-edir-extended-2.7-51.224.x86_64
deinstallation of novell-plugin-encrypted-attributes-2.7-56.219.x86_64
deinstallation of novell-plugin-encrypted-replication-2.7-56.221.x86_64
deinstallation of novell-plugin-fileman-1.3.259-1.154.x86_64
deinstallation of novell-plugin-ice-2.7-56.139.x86_64
deinstallation of novell-plugin-ifolder3-1.2.0-56.218.x86_64
deinstallation of novell-plugin-indexmanager-2.7-56.327.x86_64
deinstallation of novell-plugin-kerberos-2.7-56.213.x86_64
deinstallation of novell-plugin-ldap-2.7-62.174.x86_64
deinstallation of novell-plugin-merge-2.7-56.306.x86_64
deinstallation of novell-plugin-netstorage-3.4.2-45.135.noarch
deinstallation of novell-plugin-nmas-3.3.4-16.222.x86_64
deinstallation of novell-plugin-nss-3.6.496-1.161.x86_64
deinstallation of novell-plugin-pki-3.3.4-5.217.x86_64
deinstallation of novell-plugin-priority-sync-2.7-56.218.x86_64
deinstallation of novell-plugin-qfsearch-1.0.3-9.452.x86_64
deinstallation of novell-plugin-repair-2.7-56.328.x86_64
deinstallation of novell-plugin-rwiz-2.7-51.221.x86_64
deinstallation of novell-plugin-samba-1.0.82-10.126.noarch
deinstallation of novell-plugin-service-manager-2.7-56.348.x86_64
deinstallation of novell-plugin-single-2.7-1.293.x86_64
deinstallation of novell-plugin-sms-1.0.3-36.142.x86_64
deinstallation of novell-plugin-snmp-2.7-56.232.x86_64
deinstallation of novell-plugin-wanman-2.7-56.214.x86_64
deinstallation of novell-usermanagement-imanager-plugin-2.2.2-44.172.noarch
deinstallation of storage-iman-3.6.227-1.245.x86_64
deinstallation of novell-migration-cifs-2.0.0-1.362.x86_64
deinstallation of novell-npkiserver-3.3.5-2.418.x86_64
deinstallation of novell-migration-edirectory-0.1.0-70.481.x86_64
deinstallation of novell-kerberos-ldap-extensions-1.5-55.54.x86_64
deinstallation of novell-sasl-gssapi-method-2.8.3.2-2.61.x86_64
deinstallation of novell-NDSrepair-8.8.6.3-5.38.x86_64
deinstallation of novell-NDSserv-8.8.6.4-3.15.x86_64
deinstallation of novell-NDSimon-8.8.6.4-1.109.x86_64
deinstallation of novell-NOVLembox-8.8.6.3-5.186.x86_64
Solution 2: Following actions will be done:
replacement of NDSbase-8.7.3.7-38.i386 with novell-NDSbase-8.8.6.6-1.1.x86_64
replacement of NOVLice-8.7.3.9-2.i386 with novell-NOVLice-8.8.6.6-1.1.x86_64
Solution 3: do not install patch:oes11-edirectory-886-patch5-6108.noarch
Solution 4: break yast2-novell-schematool by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c):
#####

I'm thinking I should just choose solution 2, but I'm not sure. I definitely do not want any others. 1 would delete edir & iMgr and all of the plugins, right?. That is unacceptable. 3 is unacceptable, as is 4. What would happen if I chose 1? Would it remove eDirectory Base and iMgr? Is 2 the correct solution?

Any suggestions would be greatly appreciated.

Thanks in advance for your help.