Since update server & client 11.2.1, I had some client reported their zenworks desktop icons disappear suddenly. In the adaptive agent property page, the "device state" became "unmanaged", the "management zone", "server dns" & "server address" all changed to "unavailable". Reboot or "zac reg -g" cannot solve the problem until I unreg the machine, clean cache, and run ziswin -clear. The problem keep happening on different machine. Anyone encounter similar problem. Following is the log from a problem machine. Looks like a problem in locating server from the locationconfig file. Is it a problem relating to the location setting??


Subject: CN=server.domain.com, OU=ZENworks
Issuer: CN=server.domain.com, OU=ZENworks, O=Internal Certificate Authority
SerialNumber: 01304A90765D
NotValidBefore: 30/5/2011 17:37:19
NotValidAfter: 29/5/2021 17:37:19
Thumbprint: 817D75854903CFB95B061FF2620453E206EF9A7E
] [] []
[DEBUG] [08/24/2012 11:30:50.917] [1440] [ZenworksWindowsService] [32] [] [RegistrationModule-CertValidation] [] [Additional error info: <empty string>] [] []
[DEBUG] [08/24/2012 11:30:50.917] [1440] [ZenworksWindowsService] [32] [] [RegistrationModule-CertValidation] [] [Certificate Details:
Subject: CN=server.domain.com, OU=ZENworks, O=Internal Certificate Authority

Issuer: CN=server.domain.com, OU=ZENworks, O=Internal Certificate Authority

SerialNumber: 4DE3654E
NotValidBefore: 30/5/2011 17:37:18
NotValidAfter: 27/5/2021 17:37:18
Thumbprint: B3EBEF848592BE9D1C78AC37EEF8EE6D3930F2B3
] [] []
[DEBUG] [08/24/2012 11:30:50.917] [1440] [ZenworksWindowsService] [32] [] [RegistrationModule-CertValidation] [] [Additional error info: <empty string>] [] []
[DEBUG] [08/24/2012 11:30:50.917] [1440] [ZenworksWindowsService] [32] [] [RegistrationModule-CertValidation] [] [SslPolicyErrors.None] [] []
[DEBUG] [08/24/2012 11:30:51.214] [1440] [ZenworksWindowsService] [32] [] [CLM] [] [Unexpected exception in ProcessCommand: System.IO.DirectoryNotFoundException找不到路徑 'C:\Program Files\Novell\ZENworks\cache\zmd\locationconfig' 的一部分。
於 System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
於 System.IO.Directory.Delete(String fullPath, String userPath, Boolean recursive)
於 Novell.Zenworks.Zmd.LocationConfigBasedService.Cle arLocationConfig()
於 Novell.Zenworks.Registration.ZoneConfigManager.Cle arZoneConfig()
於 Novell.Zenworks.Registration.RegistrationCommandLi neHandler.ProcessCommandLine(Session session, List`1 cmdArgs, CommandLineOutputStream stream)
於 Novell.Zenworks.Zmd.CommandLineManager.ProcessComm and(CommandLineOutputStream stream, String command, List`1 commandParams)] [] []
[DEBUG] [08/24/2012 11:30:51.214] [1440] [ZenworksWindowsService] [32] [] [CLM] [] [After call to ProcessCommand. Result = ERROR] [] []
[DEBUG] [08/24/2012 11:30:51.214] [1440] [ZenworksWindowsService] [32] [] [CLM] [] [After call to ParseArgs. Result = ERROR] [] []
[DEBUG] [08/24/2012 11:30:51.214] [1440] [ZenworksWindowsService] [32] [] [CLM] [] [After call to StopDisplaySpinner()] [] []
[DEBUG] [08/24/2012 11:29:27.995] [1432] [zac] [4] [] [ZenCache] [] [SqliteConnection:Setting for Asynchronous IO operation to sqlite DB read from registry is null so setting it to default to true] [] []
[DEBUG] [08/24/2012 11:30:49.934] [1408] [zac] [4] [] [ZenCache] [] [SqliteConnection:Setting for Asynchronous IO operation to sqlite DB read from registry is null so setting it to default to true] [] []
[DEBUG] [08/24/2012 11:39:57.295] [1440] [ZenworksWindowsService] [38] [] [Full Disk Encryption Module] [] [Module statusStarted] [] []