New to ZCM 11 here...

We are seeing a problem with bundles/applications not showing up on the users workstation and I can't figure out what to do about it?

We upgrade an XP PC to Windows 7 with a scripted/layered imaging technique
The PC was imported/named in ZENworks 7
The ZCM Agent is installed by a script and the PC is added to the ZCM Zone (Am I getting the terminology right?)
We then add the workstation to a workstation group in ZCC
A bundle is associated to the workstation group, plus iPrint policy, workstation group policy, etc
The workstation group associated items DO NOT appear on the PC, sometimes for 24 or more hours. Sometimes it does in an hour or 2, sometimes not at all?

I have tried "ZAC CC", "ZAC REFRESH GENERAL BYPASSCACHE" on the PC with no luck. Reboots, etc. Nothing.
I have tried rebooting the PC's 1st listed management server with no change.

Once the items show up, if we re-image everything is there right from the start without delay?

Our system:
3 Primary ZCM servers (all VMWare virtual) - 1 for ZCC & imaging, 2 for workstation management (delivered via location detection & working)
All servers are ZCM version 11.2.1
Desktop agent version
1 physical Windows Server 2008 R2, with MSSQL 2008 R2 database v 10.50.1600

Is there a trick to getting this to happen faster or is this a bug?

Thanks in advance!