We have updated a satellite server from 10.3.1 to 11.1a. Now at that branch all of the 32bit windows XP machines are getting the 64bit version of the Patch Agent files when the DAU runs. The 64bit devices are working ok from what I have seen. In the zpm folder analyze.exe exists and is correct version but the file size is wrong, its 283kb when it should be 232kb. The patch agent files on server are correct.

On a couple of the broken 32bit machines I have tried to fix it by stopping the agent service, deleting the %zenworks_home%\cache\zmd folder restarting the service and starting a DAU scan. It still pulls the 64bit version of the patch agent files and the DAU fails. When I check the zenworks cache it has all the dau files present but the wrong size. I was suspecting the satellite was giving it the wrong version of the patch agents even though forcing a manual bundle verify for the dau says installing Patch_Agent_windows_x86. WTF.

I then created a new closest server rule for one test workstation and set its content to be a primary server instead of the satellite, this time it pulled and cached the correct version of analyze.exe and the DAU scan completed.

Now how could a satellite mix up the bundles like that? I ran a zac cvc to check the content and it says its peachy, is there something else to ensure content is sync'd correctly? A good way to dump all content on the satellite and re-cache?