Now that Firefox updates itself quite frequently (currently at v16) and IE10 is the only version of IE for Windows 8, is there any way to force the ZCM web site to ignore the check for which browser you are running?

I have uninstalled Firefox 16 and installed Firefox 10 as recommended in another post.

However, with the move to Firefox updating to a new version every 6 weeks or so and IE 10 moving in that direction, are we going to have to install minor updates to ZCM 11.x every couple of weeks just to use current browsers?

We use Google Apps, and they only support the two most recent versions of any web browser, so forcing people to go back 6 browser versions is not realistic.