The documentation says support for MS SQL r2 sp1.
Will sp2 work?