When you initiate an rdp connection to an xp pro computer which is running NCF, you get a popup telling you that you have logged in using fast-user switching and you can not modify settings of NCF.

This window appears even though fast user switching is disabled. Why?

Also, when the local user, logs on again, there is no NCF system tray icon, even though NCF is running (as evidenced by task manager).

How about fixing these two small annoyances?