I got Nw5.1 with sp7. I tried setting up a FTP server for fun and
friends. It works very fine in my network. I set up no anonymous
connection. I use my nds login. Works fine.

Now i wanted to to make it available to my friend outside of my
network. I used the virtual server on my router to redirect the port
21 message of my wan ip at my ftp server ip adress so that my ftp
server gets the connection request.

Now when i try at my friends location to connect to my ftp it works
almost fine. I use IE 6.0. ftp://my-ip-address then it pops up a
-ready to accept a user
-anonymous not allowed ( or sumthing like that)

I try to connect with my NDS account ( .admin.myou.myo ) and with my
password. It kind of connect cuze my ftpaudit and ftpstat record the
connection but the mouse stays like a sand glass and like 40 sec after
the connection times out.

On my status bar it says like "Listing directories". I tried to use
the "Use FTP passive mode" in advanced option of IE. Same thing.

HELP ME!! I've been trying for 6 hours everything i could imagine.
Please help me!