Our site cannot e-mail the domain "ebasetech.com".

The GWIA logs show:
10:37:26 672 MSG 5643316 Sender: Admin@ottawaheart.ca
10:37:26 672 MSG 5643316 Building message: s09cdce6.010
10:37:26 672 MSG 5643316 Recipient: drawlins@ebasetech.com

10:37:27 680 DMN: MSG 5643316 Connected to [80.71.15.36] (webmail.ebasetech.com)

10:42:29 680 DMN: MSG 5643316 SMTP session ended: [80.71.15.36] (webmail.ebasetech.com)
10:42:29 680 DMN: MSG 5643316 Send Failure: 420 TCP read error
10:42:29 128 MSG 5643316 Analyzing result file: /media/nss/DOM1/OHICO/wpgate/gwia/result/r09cdce6.010
10:42:29 128 MSG 5643316 Detected error on SMTP command
10:42:29 128 MSG 5643316 Command: EHLO smtpin.ottawaheart.ca
10:42:29 128 MSG 5643316 Response: 420 TCP read error


If I capture the packets on the GWIA server and request "Follow TCP Stream", I get:
220 ************************************************** *********************************
EHLO smtpin.ottawaheart.ca
250-ebasetech.com [207.35.222.131], this server offers 5 extensions
250-AUTH NTLM CRAM-MD5 LOGIN
250-SIZE 0
250-XXXA
250-AUTH=LOGIN
250B


I've tried reducing our MTU size on the GWIA server since this resolved "420 TCP read error" for one particulare site on our old NetWare server (We're on SLES10 now) but this didn't help.

I also tried what's suggested at this site, to disable Path MTU Discovery.
http://darenji.blogspot.co.uk/2009/0...ite-error.html

I'm just grasping right now hoping someone has other ideas?

Thanks,
Marc