Have a server(physical) running SuSE10sp2/OES2sp1 that is in need of upgrading. It is running DNS/DHCP and Iprint for this customer. Had tried to update server using online method to no avail. Move to scripts runs successfully, but the version stays the same so when you try and run the patches that are available it fails with depdencies errors since the version still thinks it is SuSE10sp2/OES2sp1. Was told by backline that only option to bring this server up to date was to upgrade using media and doing an update on it. I was also told I could take it directly to SuSE10sp4/OES2sp3 using the media, which I know you can't go directly using the online method. The main issue I have is that it is a physical server with one cdrom drive. I ran the the update on the test vm server I had to see how the process goes. When you get to the add on product to add the oes media, it gives 4 options:

Local Directory

I might try to add a second cdrom drive if I can come up with a USB drive to use. I thought the Local Directory would be an option by copying the oessp3 media to the root partition, but when I run the install and try and browse it, it shows like a temporary file system, so that wasn't an option. I know on SuSE11 it gives more options for adding that secondary media.

Guess what I am looking for to see anyone had take a server from that patch level to a current level successfully, or what are some gotchas to look out for in the process.