We experience a strange issue, which results in a second login prompt (ZCM) appearing after successful eD authentication via Novell Client on Win 7 workstations. We've applied the 11.2.2 patch, but the issue remains the same. The following can be found in the debug agent log zmd-messages :

Code:
 [DEBUG] [11/19/2012 13:12:08.438] [1596] [ZenworksWindowsService] [9] [] [Remote Management Module] [] [(RM_DEBUG)session.IsTSClientSession : False (RM_DEBUG)] [] [] 
 [DEBUG] [11/19/2012 13:12:08.438] [1596] [ZenworksWindowsService] [9] [] [Remote Management Module] [] [(RM_DEBUG)session.IsTSClientSession : False (RM_DEBUG)] [] [] 
 [DEBUG] [11/19/2012 13:12:08.438] [1596] [ZenworksWindowsService] [9] [] [ZMD] [] [Getting Session Capability] [] [] 
 [DEBUG] [11/19/2012 13:12:08.438] [1596] [ZenworksWindowsService] [9] [] [ZMD] [] [Random Refresh is enabled] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENUpdateRegStatusForLogin Entered ] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENResetConnections entered] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [ResetConnections()] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   clearing host table] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   clearing IP address table] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   clearing IP URI table] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENResetConnections returning SUCCESS] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENGetAuthoritativeSources entered] [] [] 
 [DEBUG] [11/19/2012 13:12:10.777] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [Found Authoritative sources] [] [] 
 [DEBUG] [11/19/2012 13:12:10.792] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [	MOEW-BG] [] [] 
 [DEBUG] [11/19/2012 13:12:10.792] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENGetAuthoritativeSources returning SUCCESS] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENIsServerAvailable entered] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [About to call Get Zone Config Servers:] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ZMD] [] [Getting Session Capability] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [Returned from Get Zone Config Servers:] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [Zone configuration servers are:] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [	https://zen-cmanager.moew.government.bg:443/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [	https://172.16.30.43:443/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [FindFirstContent()] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   ] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [ ] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Could not find host: zen-cmanager.moew.government.bg] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Could not find host: 172.16.30.43] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [Trying to locate source location: https://zen-cmanager.moew.government.bg/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Host name to resolve: zen-cmanager.moew.government.bg] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Adding host: zen-cmanager.moew.government.bg, status: Unknown] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Host: zen-cmanager.moew.government.bg, IP address: 172.16.30.43] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Adding IP address: 172.16.30.43] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Adding IP Uri https://172.16.30.43/ status: Unknown] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Pinging location: https://172.16.30.43/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ZenCache] [] [(Thread 23) GetObject(PROXY_OVERRIDE, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ZenCache] [] [proxy_override(public) doesn't exist in memory key cache] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ZenCache] [] [(Thread 23) GetObject returning <not cached> in 0 ms] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ZenCache] [] [(Thread 23) GetObject(PROXY_DEFAULT, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ZenCache] [] [proxy_default(public) doesn't exist in memory key cache] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ZenCache] [] [(Thread 23) GetObject returning <not cached> in 0 ms] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ZMD] [] [KeepAlive is read from registry. KeepAlive = True] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [CertManager] [] [Checking if host address 172.16.30.43 maps to cert subject zen-cmanager.moew.government.bg] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [CertManager] [] [Checking if host address 172.16.30.43 maps to cert subject zen-cmanager.moew.government.bg, alt host names are (zen-cmanager.moew.government.bg,172.16.30.43)] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan-ping] [] [   Using uri: https://172.16.30.43/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [Marking location zen-cmanager.moew.government.bg Good at the request of module RemotingService] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Setting location name zen-cmanager.moew.government.bg to status Good] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [Marking location 172.16.30.43 Good at the request of module RemotingService] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Setting location name 172.16.30.43 to status Good] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [Marking location https://172.16.30.43/ Good at the request of module RemotingService] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Setting location name https://172.16.30.43/ to status Good] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Setting location https://172.16.30.43/, IP address 172.16.30.43, and host zen-cmanager.moew.government.bg to status: Good] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Using location: https://172.16.30.43/, status: Good] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [FindFirstContent() returning https://172.16.30.43/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.680] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [It seems we have atleast one  active primary server] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [About to call Get Zone Auth Servers:] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [ZMD] [] [Getting Session Capability] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [Zone config list is:] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [	https://zen-cmanager.moew.government.bg:443/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [	https://172.16.30.43:443/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [Filtered zone config list is:] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [	https://zen-cmanager.moew.government.bg:443/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [	https://172.16.30.43:443/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [FindFirstContent()] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   ] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [ ] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Found host zen-cmanager.moew.government.bg status: Good] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Found location https://172.16.30.43/ status: Good] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [   Using location https://172.16.30.43/ status: Good] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [ConnectMan] [] [FindFirstContent() returning https://172.16.30.43/] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENIsServerAvailable returning SUCCESS] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENLogin entered] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENLogin took exception: Method not found: 'IntPtr Novell.Casa.MiCasa.OpenSecretStore(System.String)'. System.MissingMethodException: Method not found: 'IntPtr Novell.Casa.MiCasa.OpenSecretStore(System.String)'.
   at Novell.Zenworks.Zmd.Common.CasaHelper.OpenSecretStore()
   at Novell.Zenworks.Native.RemotingService.RemotingServiceImp.ZENLogin(String SessionID, String Realm, String Username, String Password, String FullDName, String SharedSecret, UInt32 LoginFlag, Boolean bZIconLogin, String()& ExtraAttribs)] [] [] 
 [DEBUG] [11/19/2012 13:12:12.695] [1596] [ZenworksWindowsService] [23] [] [RemotingService] [] [ZENLogin returning FAILURE] [] []
As you can see, the error is "Method not found". On other workstations the login process runs fine, so it should be a workstation-related issue. Any ideas?