First time posting, long time Novell user.

We are running ZCM 11.2.0 and for the most part, we manage well.

I am in the process of upgrading our server to the more recent version 11.2.2 on our servers, but I still have some clients that run on 11.1.x and one of the criteria is that we move from 11.1.x to the latest 11.2.0.x before eventually pushing out 11.2.2.x

That being said, I was curious to know how many machines we had that are still running a previous version.

I created my dynamic group with the following criteria:

1) all workstations under /devices/workstations

2) if agent version is equal to

I left it simple for now and was hoping to add to it like:

if agent version is equal to OR if agent version is equal to 11.1.11233

When the results came back, it said I have 1003 workstations with this criteria, but after looking through some of the membership, I noticed a couple that I had manually upgraded a while back, and some newer machines that had just been imaged (brand new devices under ZCM) using the latest 11.2.0 available on my server.

I am absolutely certain that the agent version on the clients are upgraded to 11.2, and even going to the workstation using ZCC shows that it has our newest available version.

Has anyone else run into this issue, and if so, how can I resolve this?

I hope to migrate our server over to 11.2.2 sooner than later as it addresses several issues that have been fixed..i.e. sat servers losing their PXE/policy when losing temp connection to primary, some bundles not appearing properly if applied to workstation groups and ppl or direct machines with specific assignments, etc.

Thanks to any who can help!