As per:

Support | How to upgrade Novell Data Synchronizer Mobility Pack Server to SLES 11 SP2

via Yast I did not manage at all (some dependencies that could not be resolved), so decided to

Booting from SLES 11 SP2 media

but I can not manage to get Mobility media recognized as an Add-On Product during install

Any ideas?

Surely it should not be that difficult to upgrade to SP ?