Earlier this year we migrated/upgraded our GW7 (NetWare 6.5) system to GW8 (SLES) and there were a few issues that we didn't pick up until a week or 2 later. Most of these have been fixed up now, but we have a few issues with our document libraries.

One of the issues we had was that DBCOPY did not copy all of the blob files (for emails and documents) across to the new server, I have been able to get the email blobs copied across and that is all working fine now.

The documents are a little different... When we did the migration we re-created the dmsh.db file and I suspect that at this stage something has gone wrong. The DBCOPY was done over 3 days with 2 passes over the data. After the migration every document created/modified after the first pass appears to have been lost. The activity log in the doc profile shows the last time it was worked on as the date before the first pass, but the document was definitely worked on the day before the 2nd pass. (ie 1st pass 19th, doc worked on 20th, 2nd pass 21st, doc profile shows the last date the doc was opened pre 19th - all changes to docs or docs created on 20th or 21st have gone). When we check the location that the profile says the document is saved in there is no blob file for it, but this would make sense as the document has been worked on and saved to a different folder, which is almost impossible to tell which folder it has been saved to. (Correct?)

When GWCheck is run on our libraries with the "Verify document files" option they are reporting Problem 86 (Inaccessible wordlist blob) and Problem 76 (Error accessing document content).

I have run the GWcheck on one of our smaller libraries with the "Reset word lists" option ticked and this has made no difference to the errors. I note that there is an option to "Fix document/version/element", can someone explain what this does? Are we able to run this option and it will find the new location of the blob based on the doc profile/database? (presuming the actual blob file is on the new server)

Are there any options I can put in the MISC tab that will find the missing blobs and restore the connection to the documents?

Hopefully someone has an answer for me so the year will end on a high....

Let me know if any of the above doesn't make sense.

Thanks in advance