The server certificate expired earlier this week. We noticed it when we started getting the following message when we went to look at a printer in the Iprint plugin for Imanager and got this error after selecting the printer.

Exception reading printer control
Internal Server Error
IPP Error: 0xF01F4
HTTP Error: 500

I recreated the server cert using the steps on from Recreating Server Certificates on OES Linux - CoolSolutionsWiki. Afterwards, when I tried to manage a printer it said tells me "The hostname of the iPrint server does not match its certificate." I click "Iprint Certificate Manager" and it comes up showing me all the info for the new certificate and has a checkbox saying "Allow the hostname <IP> to be used with this certificiate". The box is checked, click OK, and it says "Hostname <IP> now valid for certificate CN=print.<domain>" . Click OK and I go try to manage a printer and it throws the error I listed above.

The IPP page and printer installation seems to work fine still. I installed several printers to verify that part was still working. I did notice that SSL cert was for print.<domain> and the server hostname is owen.<domain>. I am not the one who configured this server, but I do know that it has always worked fine with this setup as far as I can remember.