The supporting document for iManager 2.7.6 says that when you run the binary it will upgrade the existing 2.7.x version.
However when the binary is run it errors out with a message stating....

Please install iManager through the YAST2 Open Enterprise Server Install and Configuration tool.

From within IManager you can install the npm for sp6 manually like other npm's but this will not install Tomcat 7.0.32 or Java 1.7.0_04.
So now iManager will not run.

Any one else see this or more importantly have a fix?