We're currently investigating an issue after migrating to Windows 7 and Novell Client 2 SP2. The problem has been seen with an older app written in MicroFocus COBOL and occurs on a Windows 7 machine when attempting to access a file that has been added to a file share on a Novell server. There appears to be a 20 second delay between when the files are dropped into the folder and the app is able to recognize that it is actually there. The delay is very consistent, leading me to believe a timeout is in play. It also never improves after first access to the folder, consistently staying at 20 seconds for each file accessed. I suspected that a multiple provider issue was at work, but LoginCapture Credential Provider and NetWare Services are at the top of the provider order. Here are the additional steps I've taken when troubleshooting and attempting to resolve the issue -

Disable Offline File Synchronization
Disable Autotuning
Disable Windows Search Service
Disable NTFS Last Access
Turned off Windows write-cache buffer flushing
Changed Network Provider order to Microsoft first (this is opposite of expected, but just in case, I tried it)

In Novell Client, toggled the following settings to both On and Off in all cases
- UNC Path Filter
- File Caching
- File Commit

- I also tried various combinations of Name Services with no effect.

Finally, In the registry I tried the following changes -
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\NCFSD\NetworkProvider
DeviceName Changed from \Device\NCFSD to \Device\NetwareRedirector
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\servic es\Mup
Add DisableDFS REG_DWORD and set to both 1 and 0 (currently 0)

Anyone have any additional suggestions?