I am having trouble deleting a scheduled task, specifically "Adobe Flash Player Updater.job"

In Windows Explorer, the Security settings for the file "Adobe Flash Player Updater.job" Show that both the "Administrators" group and the "SYSTEM" user have full rights.

I have a bundle requirement of "${windir}\Tasks\Adobe Flash Player Updater.job" File Exists = Yes
(Running Windows XP SP3 and ZCM 11.2.2 MU2)

I have tried a
File Removal Action "C:\Windows\Tasks\Adobe Flash Player Updater.job" With Include system files check, and "Run Action As" set to "System"

I have also tried defining my own script and setting Advanced -> Security level to both "Run as secure system user" and "Run as dynamic administrator"
In the script content I have tried both of these lines:
del /F /Q "%windir%\Tasks\Adobe Flash Player Updater.job"
schtasks /Delete /TN "Adobe Flash Player Updater"

Nothing I seem to do will remove the scheduled task. The bundle launches and seems to complete successfully, but the task is still present.

On a machine, if I browse to C:\Windows\Tasks\ in Windows Explorer I find the task. When logged in as an admin user, I am able to right click and delete the file. I'm also able to run my script contents manually from a command window when logged in as an admin user. I don't understand why my ZCM bundle won't delete the task. Any thoughts?