we have updated our primary server to 11.2.2 with the hotfix patch.

We are using ENGL for imaging our devices and they advise the 11.2.2 MU2 Update because there is a registration problem in the 11.2.2 update.
Is it a good idea to update only the primary server and satellite server to 11.2.2 MU2 to create the zen agent images for ENGL and update the managed devices "only" to 11.2.2?

If i understand the readme correct i can not update the managed devices, which are 11.2.1 directly to 11.2.2 MU2. So i have to update first to 11.2.2 and then 11.2.2 MU2 and i dont want to annoy our users with the reboots.
The Update to MU2 to the managed devices will be assigned 1 or 2 weeks later.

Is it ok to run different versions between the primary/satellite servers and the managed devices?