Hi!
One interesting problem. ZCM 11.2.2, Windows XP, so far on this device 11.2.1 (yeah, will try 11.2.2). I have a small script, nothing much. And some 150 devices where it is running via bundle during user login. And seems to on this one device it does fail. During user login first appear Windows error with ZAC (can't tell more, in events I don't see much), then several times (running script, probably) runscriptenf (in header) error, script is not fulfilled (well, sometimes it does). In agent log I see error (maybe some of these not mean anything, this user is not authenticated into zone, just local user) ...
[DEBUG] [02/12/2013 08:08:03.252] [712] [ZenworksWindowsService] [42] [] [RemotingService] [] [Unable to save the Credentails into Micasa store and Error Code is: INVALID_PARAM] [] []
...
[DEBUG] [02/12/2013 08:08:03.549] [712] [ZenworksWindowsService] [42] [] [CommonCasa] [] [MiCasa.miCASAMergeCache took exception. The error code is: -841] [] []
...
[DEBUG] [02/12/2013 08:08:03.784] [712] [ZenworksWindowsService] [36] [] [AssignmentManager] [] [Error returned from Web Service] [] []
[DEBUG] [02/12/2013 08:08:03.784] [712] [ZenworksWindowsService] [36] [] [AssignmentManager] [] [Error code: 3, Zenworks user is not authenticated.] [] []
...
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [43] [] [BundleManager] [] [ActionSet Data: <ns1:ActionSet Ordered="true" SetID="26bcdf9a14b3ce9f6ebf5a1032030d44" Type="Launch" Version="8" xmlns="http://www.novell.com/ZENworks/Actions/v1.0" xmlns:ns1="http://www.novell.com/ZENworks/Actions/v1.0"><CurrentActionItem>0</CurrentActionItem><Action ContinueOnFailure="false" Enabled="true" Id="97e29b202559a5d34313140aa02c8d69" Type="Run Script Action" Undo="false"><Name>Run Script for Homedir selection</Name><Data><ns1:RunScriptActionHandlerData xmlns="http://www.novell.com/ZENworks/Actions" xmlns:ns1="http://www.novell.com/ZENworks/Actions"><Exec maxTimeToWait="-1" terminateProgram="false"><ns2:Script extension=".cmd" xmlns="http://www.novell.com/ZENworks/Controls" xmlns:ns2="http://www.novell.com/ZENworks/Controls">subst.exe w: h:\
if %errorlevel% == 0 goto end
subst.exe w: z:\
if %errorlevel% == 0 goto end
subst.exe w: "C:\Documents and Settings\guest"
:end
</ns2:Script><ns2:ProgramExecutor arguments="/C" path="C:\WINDOWS\system32\cmd.exe" xmlns="http://www.novell.com/ZENworks/Controls" xmlns:ns2="http://www.novell.com/ZENworks/Controls" /><ns2:AdvancedSettings xmlns="http://www.novell.com/ZENworks/Controls" xmlns:ns2="http://www.novell.com/ZENworks/Controls"><SuccessReturnCode>0</SuccessReturnCode><SuccessReturnCode>1</SuccessReturnCode><Priority>Normal</Priority><RunAs>User</RunAs></ns2:AdvancedSettings></Exec></ns1:RunScriptActionHandlerData></Data><Properties><Name>Impersonation</Name><Value>USER</Value></Properties><Properties><Name>StandaloneName</Name><Value>runscriptenf</Value></Properties><Any><Reqs><ReqsFailAction>false</ReqsFailAction></Reqs><actionUniqueId>95be84d545824da1eaa6e1e138980 d1f</actionUniqueId></Any></Action></ns1:ActionSet>] [] []
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [35] [] [ZIconMod] [] [Received exception closing the activityIndicator to user session (2002073): Failed to connect to an IPC Port: The system cannot find the file specified.


Server stack trace:
at System.Runtime.Remoting.Channels.Ipc.IpcPort.Conne ct(String portName, Boolean secure, TokenImpersonationLevel impersonationLevel, Int32 timeout)
at System.Runtime.Remoting.Channels.Ipc.ConnectionCac he.GetConnection(String portName, Boolean secure, TokenImpersonationLevel level, Int32 timeout)
at System.Runtime.Remoting.Channels.Ipc.IpcClientTran sportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
at System.Runtime.Remoting.Channels.BinaryClientForma tterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at (0):
at System.Runtime.Remoting.Proxies.RealProxy.HandleRe turnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateI nvoke(MessageData& msgData, Int32 type)
at Novell.Zenworks.NotifyIcon.Remoting.IZenIconUIServ er.CloseActivityIndicator(String guid, String status, String name)
at Novell.Zenworks.NotifyIcon.Module.ZenNotifyIcon.Cl oseActivityIndicator(Session session, String guid, String status, String name)] [] []
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [35] [] [BundleManager] [] [After InstallApp] [] []
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [35] [] [BundleManager] [] [inside result != null] [] []
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [35] [] [BundleManager] [] [Before calling UpdateLastRunTime(false) ] [] []
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [35] [] [BundleManager] [] [UpdateLastRunTime Method False] [] []
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [35] [] [BundleManager] [] [After GetLocalStateInfoNovell.Zenworks.AppModule.AppLoca lState] [] []
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [35] [] [BundleManager] [] [GetLocalStateRecord :: Current Session ID : 2002073, UserName : guest] [] []
[DEBUG] [02/12/2013 08:08:26.549] [712] [ZenworksWindowsService] [38] [] [ZIconMod] [] [Received exception adding progress to user session (2002073): Failed to connect to an IPC Port: The system cannot find the file specified.


Server stack trace:
at System.Runtime.Remoting.Channels.Ipc.IpcPort.Conne ct(String portName, Boolean secure, TokenImpersonationLevel impersonationLevel, Int32 timeout)
at System.Runtime.Remoting.Channels.Ipc.ConnectionCac he.GetConnection(String portName, Boolean secure, TokenImpersonationLevel level, Int32 timeout)
at System.Runtime.Remoting.Channels.Ipc.IpcClientTran sportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
at System.Runtime.Remoting.Channels.BinaryClientForma tterSink.SyncProcessMessage(IMessage msg)

Exception rethrown at (0):
at System.Runtime.Remoting.Proxies.RealProxy.HandleRe turnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateI nvoke(MessageData& msgData, Int32 type)
at Novell.Zenworks.NotifyIcon.Remoting.IZenIconUIServ er.AddProgress(ITaskSetProgress progress)
at Novell.Zenworks.NotifyIcon.Module.ZenNotifyIcon.Ad dProgress(Session session, ITaskSetProgress progress)] [] []
...
[DEBUG] [02/12/2013 08:08:33.346] [712] [ZenworksWindowsService] [25] [] [ZMD] [] [Finished Processing Command for handler refresh. Result = ERROR] [] []
[DEBUG] [02/12/2013 08:08:33.346] [712] [ZenworksWindowsService] [25] [] [CLM] [] [After call to ProcessCommand. Result = ERROR] [] []
[DEBUG] [02/12/2013 08:08:33.346] [712] [ZenworksWindowsService] [25] [] [CLM] [] [After call to ParseArgs. Result = ERROR] [] []
...
[DEBUG] [02/12/2013 08:10:18.831] [712] [ZenworksWindowsService] [43] [] [BundleManager] [] [Error Processing Bundle Action for bundle: Homedir select] [] []
[DEBUG] [02/12/2013 08:10:18.831] [712] [ZenworksWindowsService] [43] [] [BundleManager] [] [Error is: Exception was: Object reference not set to an instance of an object.] [] []
[DEBUG] [02/12/2013 08:10:18.831] [712] [ZenworksWindowsService] [43] [] [BundleManager] [] [Got exception while processiong the action set - Exception of type 'Novell.Zenworks.AppModule.LaunchException' was thrown.
at Novell.Zenworks.AppModule.AppActionItem.ProcessAct ion(APP_ACTION launchType, ActionContext context, ActionSetResult previousResults)
at Novell.Zenworks.AppModule.AppActionItem.ProcessHan dledAction(APP_ACTION launchType, ActionContext context, ActionSetResult previousResults) ] [] []
[DEBUG] [02/12/2013 08:10:18.831] [712] [ZenworksWindowsService] [43] [] [BundleManager] [] [The launch exception reason is ACTION_SET_FAILURE] [] []
[DEBUG] [02/12/2013 08:10:18.831] [712] [ZenworksWindowsService] [43] [] [BundleManager] [] [ActionMan.ExceptionString] [] []
[DEBUG] [02/12/2013 08:10:18.831] [712] [ZenworksWindowsService] [43] [] [BundleManager] [] [!!!!! Failure processing scheduled item !!!!!] [] []
[DEBUG] [02/12/2013 08:10:18.831] [712] [ZenworksWindowsService] [43] [] [BundleManager] [] [Attempting to retry] [] []
...
And it tries several times ... end with error.
When I disable this script bundle running just zac-error appear during login, don't know why. Devices is setup very similar way. But ... on this device in question is also Microsoft Visual Studio 6 (version before 2005) installed. In other hand ... with ZCM 10 agent installed on same device ... no problem, so ... . Maybe it is not so big problem, but this device is located in lecture room and it (errors) does confuse teachers.
More thanks, Alar.