we are rolling out a new ZCM Agent on Win7 x64 SP1 German: 11.2.2MU1.
More than the half of the devices (which have 11.1.x-Agent) run in an
error ("One or more pre-requisite updates failed to install to this
device....). So i stopped the rollout after 10 devices got this error.
On some devices i tried to install the agent manually. At first i tried
to remove the agent with the Agent cleanup tool. After using this tool i
wasn't able to login to the device. I found TID 7009577 where this error
is described, the mentioned registry tweak helped me. I am using version but the error still occurs(the TID says it is fixed in I was able to reinstall the agent so this device has the
new agent. What a nightmare!

The next issue are the errors: More than the half of my devices show the
error "One or more pre-requisite updates failed to install to this
device. Ensure all pre-requisite updates have been applied successfully
and try again." I don't know which pre-requisites fail, the failing
devices are all on 11.1., so the pre-requisites should be the same. I
read some threads about this error but this did not help me.
The error in the system-update.log MSI-Error 1601 when installing the
Any help would be appreciated.

Kind regards,